Lines don't show in Apparance editor (unreal)

Hello,

The last modifications made the lines visible. Now it only leave the problem with the property panel.

Oh my goodness. Progress. There must be something wrong with the bool2double converter, or opacity handling. Did the first change above not affect the property panel?

There are no change in the property panel. The last screenshot I did was realised after the last modifications I realized and with a node selected. There is still only the number caused by one of the first modification and the names of the node’s input. But I still can’t set any default value for those inputs.

Yeah, there are other Opacity operators in there. Currently it looks like the BooleanToDouble converter is failing for some reason (the default is to return 0, hence transparent opacity level). It’s not obvious why though. Can you try the following for me please:

  1. Find the lines where Opacity is set using the bool2vis converter. (the property panel ProcedureOperator Custom UI section has a couple of them.)
  2. Enclose the ConverterParameter values (e.g. the 0.5|1.0 part after the equals)` with single quotes, e.g.:
    <Grid Opacity="{Binding IsConnectedToConstant, Converter={StaticResource bool2double}, ConverterParameter='0.5|1.0'}">
  3. Ctrl+S each edited page and see if things appear.

Hi,

Sorry for the late answer but I didn’t have time for myself those last days. I have yet to do the last modification and because of a stupid error from myself, I needed to reinstal unreal engine 4.27 (and the plugin which make me lose the previous modifications).
I noted that if I modified the xaml files in a text editor, the apparance editor reset them to the state before the modifications. Is there a way to block this to happen? I noted that there is a lot of ConverterParameter values in the different files and as the lines are not numbered in the apparence editor, it take a while to be sure that I have enclosed all the values in single quotes.

Oh, yeah, it validates the install to ensure it’s not broken, reinstalling if needed :expressionless:
I’ll have to think about how to allow that in some cases. You can take a copy of the changes to copy back after, or, if you run the editor manually instead of launching it from the Unreal menus it will connect and Unreal won’t try and reinstall it.
Once we have a fix or workaround, or at least an understanding of what’s going on I will roll out a proper fix.
Let me know how you get on.

I may have just worked out what the issue is here. You are using Windows in a French locale aren’t you? (I see what I think is French in settings screenshot) So does this mean you use comma ‘,’ as the decimal separator, e.g. 3,141592? This would affect the internal parsing of some of the Opacity values which are expressed as 1.0 and 0.5 etc. You can try changing just those to use commas, e.g. the “0.2|1.0” → “0,2|1,0”. Don’t worry about any of the things we tried above.
I need to make a code change for this to be a general fix, but I’ll roll it out with a bunch more fixes I’m working on today and tomorrow.

Hello,

Sorry, I still didn’t have the time to do the modification. I think I will try next week-end.
Concerning the modification where I enclose the ConverterParameter values with single quote should I use a comma " ’ " (bellow the number 4 on an azerty keyboard) or the quote " ` " (alt + number 7 on an azerty keyboard)?
I do use Windows with French locale. But I don’t think it would affect the usage of quote and dot in a specific programming language. Maybe I can change the regional parameter used for non unicode programs before trying to modify the dot in quote? Can you tell me what you use?

Hi, don’t worry about the quotes around the numbers, can you try the comma instead of the dot in the decimal values shown above please. I think we’re very close to tracking this down. No rush though :slight_smile:

Hi,

I just saw that an update of the plugin was available. I downloaded it and both the line and the property editor was fixed. I can see the nodes inputs and modify them.

Just a remark concerning the update, in my case, the old version of the editor was deleted in the binaries folder and to download it, I needed to create a new project in which I activated the plugin. I couldn’t download it directly when I opened the example project. Maybe it would be useful to add a button in the apparence toolbar to download the editor?

Thank you for your help.

1 Like

Yay, I think we found the problem. Thankyou soooo much for the patient help.

The plugin version and editor version are linked and it should auto-download the new version when you try to open it. This is the same reason the editor kept resetting on restart. Did this not happen?

:white_check_mark: Marking this issue as fixed in version 1.2.3.

Hello,

After installing the update, I first opened a project with the plugin already activated. I tried to open the editor but nothing appened. When I checked the binaries folder in the plugins/marketplace/apparence folder, it was empty.
To download the plugin, I needed to create a new project, to activate the plugin and restart the project. Then, I add a windows that set up the plugin and downloaded the editor during the process.

Ok, thankyou, please let me know if this happens again and I’ll start investigating. For now I’d put it down to the unusual dev activity we’ve been going through. :confused: